Degraded Performance on Job Boards
Incident Report for Greenhouse
Postmortem

Around 3:40 PM Eastern Time, Greenhouse became aware of backed-up queues related to our job board APIs. We identified the incident at 4:04 as a Denial of Service attack affecting one of our customers which was being passed through to our job board APIs. At 4:12 PM, we blocked the IP addresses that were causing the degraded performance and the job board system began its recovery.

This incident would have appeared as slow processing on candidate applications and job boards between 3:17 PM and 4:12 PM Eastern Time. Greenhouse will be exploring ways to mitigate attacks of these time going forward.

Posted Aug 13, 2021 - 22:44 EDT

Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 16:55 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2021 - 16:22 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 13, 2021 - 16:14 EDT
Investigating
Some customers are reporting issues with candidates trying to apply to jobs. We are currently investing.
Posted Aug 13, 2021 - 15:58 EDT
This incident affected: Greenhouse Job Boards.