Partial Service Disruption - Job Boards

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted May 01, 2025 - 19:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2025 - 18:33 UTC

Investigating

We are currently experiencing a partial disruption affecting internal and external job boards of Greenhouse Recruiting. Our team is investigating the issue and working to restore full functionality. We apologize for any inconvenience and will provide updates as we have more information.
Posted May 01, 2025 - 17:01 UTC
This incident affected: Greenhouse Job Boards.