Indeed Apply applications missing answers to some job post questions
Incident Report for Greenhouse
Resolved
We have implemented a fix and Indeed Apply applications are working as anticipated.
Posted Mar 29, 2024 - 14:58 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 29, 2024 - 11:10 EDT
Investigating
We're investigating reports of applications submitted through Indeed Apply missing answers to some job post questions
Posted Mar 29, 2024 - 10:56 EDT
This incident affected: Greenhouse Job Boards.