MailDrop Errors
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 08:38 EDT
Investigating
We are investigating reports of users receiving a failed delivery attempt when mentioning internal users on candidate profiles, scheduling interviews and logging candidate conversations via MailDrop.
Posted Jun 26, 2023 - 06:03 EDT
This incident affected: Greenhouse Recruiting (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 7, Silo 101).