Adobe Acrobat Sign experiencing issues sending for signature

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted May 28, 2026 - 18:29 UTC

Investigating

Some customers are experiencing errors while trying to send offers for signature. Adobe is currently experiencing an issue and they are investigating. We will continue to monitor the situation from our side.
Posted May 28, 2026 - 16:23 UTC
This incident affected: Third-Party Integrations (Adobe Acrobat Sign).