BIC: Data is delayed

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 10:32 UTC

Identified

We are experiencing delays in updates to the Business Intelligence Connector data. Customers using BIC might be not have up-to-date data available in these tables for data. We have identified the issue and are working on a fix.
Posted Jul 28, 2025 - 18:08 UTC
This incident affected: Greenhouse Business Intelligence Connector (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 7, Silo 8, Silo 9, Silo 101, Silo 201).