Our engineering team has released a workaround that restores Microsoft Teams links when scheduling on shared calendars. Affected customers have been contacted by Support with next steps. If you continue to experience this issue, please contact Greenhouse Support.
Posted Sep 03, 2026 - 20:00 UTC
Update
Microsoft has confirmed the root cause is on their side and continues to investigate. While we await a fix from Microsoft, our engineering team has developed a workaround that restores Teams meeting links when scheduling on shared calendars. It has been validated successfully with a small group of affected customers, and we are working to make it available more broadly. We will share an update as soon as it is ready. Thank you for your patience.
Posted Sep 02, 2026 - 18:37 UTC
Identified
It appears that the issue is related to the Graph API. Our engineering team is in contact with Microsoft Support to help them diagnose the problem.
Posted Aug 07, 2026 - 14:30 UTC
Investigating
We are currently experiencing an issue with the Microsoft Teams integration that affects scheduling interviews on shared calendars. Our Engineering team is actively investigating the root cause. We will continue to provide updates as more information becomes available.