Issues Scheduling Interviews for Outlook365 Users
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted 4 months ago. May 29, 2019 - 14:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 29, 2019 - 12:35 EDT
Identified
We have identified an issue causing some Outlook365 users to experience errors when scheduling. We are currently working on a fix.
Posted 4 months ago. May 29, 2019 - 10:52 EDT
This incident affected: Greenhouse Products (Greenhouse Interview Scheduling).