BIC: Delays in delivering data for Silo 1

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 13:02 UTC

Investigating

We are currently experiencing a delay for Silo 1 in BIC data delivery.
Posted Jun 18, 2026 - 12:35 UTC
This incident affected: Greenhouse Business Intelligence Connector (Silo 1).