Job boards are not being updated

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Jul 28, 2023 - 16:12 UTC

Monitoring

We've worked through our backlog of Job board updates. All changes show now be live. We'll continue monitoring.
Posted Jul 28, 2023 - 15:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2023 - 14:07 UTC

Investigating

Users are experiencing lengthy delays when making changes to their job boards.
Posted Jul 28, 2023 - 12:10 UTC
This incident affected: Greenhouse Job Boards.