Degraded Performance for Greenhouse Business Intelligence Connector for Silo 1
Incident Report for Greenhouse
Postmortem

WHAT HAPPENED?

On May 26, 2021, an outage with a third-party tool caused Business Intelligence Connector (BIC) ETLs to not complete. To resolve the failure, some customers were moved to a slower legacy ETL system, which caused delays.  We returned to the new system before the third-party tool was fully fixed, which caused impartial data to be delivered on June 1st and June 2nd.

TIMELINE

May 26, 2021

13:19 UTC: Greenhouse team notices that BIC ETLs will not complete on time due to a third-party tool outage.

19:31 UTC: Greenhouse moves ETLs to a legacy system to resolve the issue.

May 28, 2021

19:40 UTC: Third-party notifies Greenhouse that the issue is resolved.

20:40 UTC: Greenhouse restores the new ETLs.

June 1, 2021

20:01 UTC: Greenhouse team is made aware that Silo 1 customers are missing data in BIC. This was caused by an incomplete resolution to the May 26 outage.

June 2, 2021

02:53 UTC: Greenhouse moves Silo 1 customers to the legacy ETL to mitigate impact.

12:00 UTC: Greenhouse team is made aware of delivery delays on Silo 2, 3, and 4 with 23 out of 71 tables still in progress.

20:13 UTC: ETLs on Silo 2, 3, and 4 complete.

June 3, 2021

15:07 UTC: The incident is fully resolved and data delivery is restored.

WHAT WAS THE EFFECT?

On May 26, Silo 1 customers experienced delays with the ETL, resulting in partial data availability.

On June 1, Silo 1 customers experienced incomplete data.

On June 2, Silo 2, 3, and 4 customers experienced delays with the ETL, resulting in partial data availability.

Here’s how to check which Silo your organization is on.

WHAT WAS THE CAUSE?

The cause was an outage from our third-party ETL provider.

WHAT ARE WE DOING TO PREVENT THIS FROM OCCURRING AGAIN?

  • We are improving our alerting for incomplete data loads.
  • We are increasing customer communication when data fails to load or loads partially.

If you have any questions or concerns, please reach out via our support center.

Posted Jun 04, 2021 - 15:56 EDT

Resolved
This issue is resolved. We will be sharing a public post-mortem regarding the incident.
Posted Jun 03, 2021 - 11:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2021 - 16:22 EDT
Investigating
Silo 1 Business Intelligence Connector customer's data has not been synchronized overnight. We are investigating the cause.
Posted Jun 02, 2021 - 11:18 EDT
This incident affected: Greenhouse Business Intelligence Connector (Silo 1).