Issues Saving Resumes
Incident Report for Greenhouse
Postmortem

WHAT HAPPENED?

On Jul 17, 2019 at 15:00 UTC, Greenhouse released an update to its Job Board service that caused new job applications to be missing attachments for some customers.

On Jul 18, 2019 at 16:08 UTC, the Job Board service was rolled back to a previous version that fixed the issue.

WHO WAS AFFECTED?

Customers who integrate with Option 5 (API-only) job boards and attach resumes using the “Direct upload” method with a Content-Type of application/json (see https://developers.greenhouse.io/job-board.html#submit-an-application for reference.

Additionally, applications submitted by third-party integrations using the Job Board API were also affected.

Any affected organization was notified via email on July 17.

WHAT WAS THE CAUSE?

When we updated the Job Board service to use a new version of software, we failed to address a backward-incompatible change in the new software. This resulted in attachments being ignored and stripped from applications before being imported into Greenhouse Recruiting.

WHAT ARE WE DOING TO PREVENT THIS FROM OCCURRING AGAIN?

The issue was not caught in testing because there were no automated test over the specific feature that was affected. We’ve since added an automated test to our test suite that will prevent a similar issue from recurring in the future.

Posted about 2 months ago. Jul 23, 2019 - 17:33 EDT

Resolved
This incident has been resolved. We will provide a postmortem on this issue soon.
Posted about 2 months ago. Jul 18, 2019 - 12:53 EDT
Identified
Our team has isolated the issue affecting some resumes submitted via the Job Board API. We have implemented a fix and any new resumes submitted should be saving properly. We are monitoring for further errors and will provide an update shortly.
Posted about 2 months ago. Jul 18, 2019 - 12:16 EDT
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Jul 18, 2019 - 12:14 EDT
Investigating
We have identified an issue where some resumes submitted via job post applications are not being properly saved. Our team is currently investigating.
Posted about 2 months ago. Jul 18, 2019 - 11:50 EDT
This incident affected: Greenhouse Products (Greenhouse Job Boards).