Performance Degradation
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 20:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2025 - 19:36 UTC
Investigating
We are currently experiencing issues with latency on Silo 3. Users may notice slower page loads until the issue is resolved. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
Posted Jan 21, 2025 - 18:45 UTC
This incident affected: Greenhouse Recruiting (Silo 3).