Partial Service Disruption

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 22:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 20:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 13, 2025 - 20:47 UTC

Update

We are continuing to investigate the issue and are working closely with our email provider.
Posted Nov 13, 2025 - 15:20 UTC

Investigating

We are currently experiencing a partial disruption resulting in bounced error messages when sending emails to Greenhouse managed email addresses. Our team is investigating and working to restore full functionality. We apologize for the inconvenience and will share updates as they become available.
Posted Nov 13, 2025 - 11:07 UTC
This incident affected: Greenhouse Recruiting (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 7, Silo 8, Silo 9, Silo 101, Silo 201).