Some users may be experiencing slow load times and occasional errors

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Mar 29, 2021 - 15:45 UTC

Monitoring

The issue increasing load time and error rates for some users has been resolved. We will continue monitoring performance closely.
Posted Mar 29, 2021 - 15:14 UTC

Identified

We've identified the cause of slow response times. Most response times have returned to normal, but we are continuing to work on the issue.
Posted Mar 29, 2021 - 14:58 UTC

Investigating

We are investigating an issue with slow load times and some users seeing intermittent error message.
Posted Mar 29, 2021 - 14:24 UTC
This incident affected: Greenhouse Recruiting (Silo 1).