Delayed Job Post and Job Board Changes
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 07:57 EDT
Monitoring
Delays on updates to job posts and job boards have improved. We will continue to monitor the situation.
Posted Oct 31, 2022 - 19:26 EDT
Investigating
We are experiencing delays for updates made to job posts and job boards in Greenhouse being reflected on external career pages. Our engineers are working to correct this and will update this page once fully resolved.
Posted Oct 31, 2022 - 17:38 EDT
This incident affected: Greenhouse Recruiting (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 101) and Greenhouse Job Boards.