Some job posts not appearing

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 01:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 00:25 UTC

Investigating

We are investigating an issue where some live job posts in Greenhouse are not appearing correctly on external job boards and may show as closed or offline.
Posted Mar 25, 2026 - 00:04 UTC
This incident affected: Greenhouse Job Boards.