Were are experiencing slow updates to changes to candidates and applications being updated in the search interface

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 16:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 31, 2026 - 19:14 UTC
This incident affected: Greenhouse Recruiting (Silo 1).