Dashboard Loading Slowly
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted May 21, 2024 - 19:24 UTC
Update
We identified a process that was erroneously creating "service user" accounts since May 17 4:05 PM EST. The slowness experienced and error message on the Job Setup tab are related to the application having to load these accounts even though they are never used.

We are in the process of removing these accounts from our database.
Posted May 21, 2024 - 13:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2024 - 19:53 UTC
Investigating
We are investigating reports of errors or slowness when viewing the Dashboard and Job Setup tab in Greenhouse Recruiting.
Posted May 20, 2024 - 18:46 UTC
This incident affected: Greenhouse Recruiting (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 7, Silo 8, Silo 101).