BIC: Data is delayed

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 18:10 UTC

Update

This issue is related to an outage caused by an upstream vendor. We are monitoring the situation to determine next steps.
Posted Oct 20, 2025 - 21:19 UTC

Identified

We are experiencing delays in updates to the Business Intelligence Connector data. Customers using BIC will not have up-to-date data available in these tables.
Posted Oct 20, 2025 - 17:16 UTC
This incident affected: Greenhouse Business Intelligence Connector (Silo 1, Silo 2, Silo 3, Silo 4, Silo 5, Silo 6, Silo 7, Silo 8, Silo 9, Silo 101, Silo 201).