Difficulty scheduling with Microsoft Outlook

Incident Report for Greenhouse

Resolved

Microsoft has confirmed recovery of their systems
Posted Jun 05, 2023 - 18:04 UTC

Monitoring

Currently, we are not detecting any errors with our Outlook integration. We will continue to monitor this service.
Posted Jun 05, 2023 - 16:57 UTC

Identified

Outlook is currently experiencing degraded service and you may experience difficulty scheduling interviews via Outlook. We're monitoring their service for changes.
Posted Jun 05, 2023 - 15:01 UTC
This incident affected: Third-Party Dependencies (Outlook 365).