Intermittent Harvest v3 Timeouts

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted May 20, 2026 - 15:41 UTC

Investigating

Some customers are experiencing timeouts and errors when making requests to Harvest v3 on Silo 1. We are currently investigating this issue.
Posted May 20, 2026 - 15:05 UTC
This incident affected: Greenhouse Harvest API (Silo 1).