Issues accessing the Greenhouse Marketing Site and Help Center
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 19:16 EST
Update
You can login to the Greenhouse Recruiting app from https://app.greenhouse.io or via your company SSO provider.
Posted Feb 01, 2021 - 17:56 EST
Investigating
We are investigating issues with the Greenhouse Marketing site (https://www.greenhouse.io) and the Help Center (https://support.greenhouse.io)
Posted Feb 01, 2021 - 16:34 EST